网站链接: ngui
当前位置: 首页 > 学习教程  > 互联网媒体

Debian 安装steam client记录

2021/1/12 16:47:12 人评论 文章标签: steam怎么安装

1.下载steam安装https://store.steampowered.com/about/ sudo dpkg -i steam_latest.debSelecting previously unselected package steam-launcher. (Reading database ... 202509 files and directories currently installed.) Preparing to unpack steam_latest.deb ... Unp…

1.下载steam安装https://store.steampowered.com/about/

sudo dpkg -i steam_latest.deb

Selecting previously unselected package steam-launcher.
(Reading database ... 202509 files and directories currently installed.)
Preparing to unpack steam_latest.deb ...
Unpacking steam-launcher (1.0.0.61) ...
dpkg: dependency problems prevent configuration of steam-launcher:
 steam-launcher depends on python-apt; however:
  Package python-apt is not installed.

dpkg: error processing package steam-launcher (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:

2.提示python-apt未安装;执行apt修复broken,自动安装

sudo apt-get install -f

3.运行,提示缺少32位的库

4.安装sudo apt-get install libgl1-mesa-glx:i386;提示libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast

5.我debian安装了nvidia最新的驱动430.14;没有32位libGL。安装mesa的似乎没用;参考https://wiki.debian.org/Steam

需要安装libgl1-nvidia-glx:i386(添加“non-free”至apt sources),但这个会覆盖最新的nvidia驱动;放弃。

(Nvidia驱动里有32位libGL或者steam只运行64位???)

sudo ln -s /usr/lib/x86_64-linux-gnu/libGL.so.1 libGL.so.1
sudo ln -s /usr/lib/x86_64-linux-gnu/libdrm.so.2 libdrm.so.2
#试试链接64位的无效

6.解压NVIDIA官方驱动,发现里面包含了32位的驱动,可能安装的时候没有添加32位架构,没有安装;退出图形xserver,重新运行安装run文件,安装兼容32的驱动(有提示选择是否安装)

# dpkg --add-architecture i386
# apt update
# sudo init 3
#ctrl+alt+F1
# sh nvidia...run

7.重启后/usr/lib/i386-linux-gnu/里有了32位驱动LibGL.so,但还是没有libdrm.so,安装libdrm2:i386

neil@debian99:~/Desktop$ sudo apt-get install libdrm2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  libdrm2:i386
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/38.8 kB of archives.
After this operation, 111 kB of additional disk space will be used.
Selecting previously unselected package libdrm2:i386.
(Reading database ... 202585 files and directories currently installed.)
Preparing to unpack .../libdrm2_2.4.74-1_i386.deb ...
Unpacking libdrm2:i386 (2.4.74-1) ...
Setting up libdrm2:i386 (2.4.74-1) ...
Processing triggers for libc-bin (2.24-11+deb9u4) ...

可以看到libdrm.so和libGL.so都有了,运行steam,成功,Dota2正常运行。

8.在线更新后,启动会报一大堆错,并且右下角右键退出不可用,主要是steam是32位程序,需要安装一大堆i386库:

#Gtk-Message: Failed to load module "gail"
#Gtk-Message: Failed to load module "atk-bridge"
sudo apt-get install libatk-adaptor:i386 libgail-common:i386

#GTK theme error: Unable to locate theme engine in module_path: "pixmap"
sudo apt-get install  gtk2-engines-pixbuf:i386

#Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita"
sudo apt-get install gnome-themes-standard(安装主题,可以不安装吧)

 

本文链接: http://www.dtmao.cc/news_show_539447.html

附件下载

相关教程

  • 关于APEX安装出现的错误

    APEX安装错误解决记录链接: link.找了好久的解决方法,CUDA版本一直对着,GCC也没错,一直报编译错误。 后来按照链接里的把torchvision降为0.5.0,成功安装APEX扩展版本。

    2021/1/12 16:47:29
  • deepin安装软件失败的解决方法

    deepin安装软件总是失败。 更新系统也没用,换源也没有用。 商店提示网络错误。 现在在这里推荐一个方法,亲测有效。 打开终端 输入以下命令 sudo dpkg --configure -a这个过程可能会很缓慢。 弄完之后就可以正常安装软件了。

    2021/1/12 16:47:28
  • steam无法安装32的包

    在ubuntu14.04上使用steam的时候,估计是不小心删除了某些文件,一直提示要安装 libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386 但是安装发现总是失败。 后来看了一篇文章发现安装安卓源码也需要安装这些包,谷歌给的解决方法是安装别…

    2021/1/12 16:47:27
  • 解决origin平台安装慢的办法

    目录// _ooOoo_ // // o8888888o // // 88" . "88 // // (| ^_^ |) /…

    2021/1/12 16:47:26
  • UE4配置Steam只需简单三步

    首先效果图 1,开启Stueam的插件 2,修改配置文件 DefaultEngine.ini [URL][/Script/HardwareTargeting.HardwareTargetingSettings] TargetedHardwareClassDesktop AppliedTargetedHardwareClassDesktop DefaultGraphicsPerformanceMaximum AppliedDefa…

    2021/1/12 16:47:25
  • steam 下载游戏时无法连接到服务器

    方法一:更换下载节点 具体:1. 找到steam | settings 2. 找到setting | Downloads 3. 更换 Download Region 可以每一个都试试 转载于:https://www.cnblogs.com/Jhon-Y/p/7074433.html

    2021/1/12 16:47:21
  • archlinux 64安装steam

    steam现在发布了正式版,但是只有deb包,并且只有32版本。在debian的衍生版本里边直接安装就可以。其他版本需要自己做一些工作了。 archlinux安装steam有两种方式,一种是直接从aur中安装,另一种是直接使用deb包来自己安装。 先说…

    2021/1/12 16:47:19
  • fedora上安装steam

    补充: 据称steam现已被添加到rpmfusion源中。 下载repo文件,复制到/etc/yum.repos.d目录下 http://spot.fedorapeople.org/steam/steam.repo 或者复制以下内容,保存为steam.repo # Place this file in your /etc/yum.repos.d/ directory…

    2021/1/12 16:47:18
  • ubuntu安装steam

    增加第三方自由库的软件支持 sudo add-apt-repository multiverse 增加更新支持包 sudo add-apt-repository multiverse 安装steam sudo apt install steam 修复依赖关系 sudo apt-get -f install 转载于:https://www.cnblogs.com/RogerLu/p/9905103.html

    2021/1/12 16:47:17
  • nginx1.14.0安装

    nginx1.14.0安装yum install pcre pcre-devel -yyum install -y openssl openssl-develuseradd nginx -s /sbin/nologin -Mcd /root/wget -q http://nginx.org/download/nginx-1.14.0.tar.gztar xf nginx-1.14.0.tar.gz cd nginx-1.14.0./configure --usernginx --groupnginx -…

    2021/1/12 16:47:16
  • Debian 安装steam client记录

    1.下载steam安装https://store.steampowered.com/about/ sudo dpkg -i steam_latest.debSelecting previously unselected package steam-launcher. (Reading database ... 202509 files and directories currently installed.) Preparing to unpack steam_latest.deb ... Unp…

    2021/1/12 16:47:12

共有条评论 网友评论

验证码: 看不清楚?